Stargate CrashLoopBackOff due to failed liveness/readiness probes

The stargate pod suddenly became unresponsive so I tried to kill the pod to force a restart.

Now it doesn’t start. Over the weekend it had 382 restarts before it got up, but something was wrong when I tried to connect to it using cqlsh. Got the error: Error from server: code=0100 [Bad credentials] message=“Unable to perform authentication: Operation timed out - received only 0 responses.”

I tried restarting the pod again and now it is back to CrashLoopBackOff status.

Any clues?

Hi @morten-holm,

could you share the logs of the failed startups? Note that you can get the logs from a previous run using: kubectl logs pod/.... --previous

This will help us understand what’s going on.
Also, could you tell us which version of K8ssandra or k8ssandra-operator you’re currently using, and what’s the topology of your cluster? Your helm values file or K8ssandraCluster manifest would be useful to see which settings you’ve been using.