K8ssandra Forum

Can't deploy medusa on system that have no internet access

Hello,

My issue is during the helm command to install the k8ssandr backup feature.
I run the following helm command:

helm --debug upgrade -f /hyperfile/cluster/kubernetes/cassandra_backup_enabled.yaml cassandra /hyperfile/cluster/kubernetes/k8ssandra-1.2.0.tgz -n cass-operator

I just noticed in the logs that it tries to connect to internet

2021/09/23 13:55:35 Upgrading CRDs to version 1.2.0 2021/09/23 13:55:36 Downloading release 1.2.0 from Helm repository 2021/09/23 13:55:45 Failed to update CRDs: Get “https://helm.k8ssandra.io/index.yaml”: dial tcp 104.26.10.75:443: connect: no route to host

That happens when it run the job cassandra-crd-upgrader-job

I need to run the installation on kube cluster that are not connected to internet.
So how can I install it on a system that have no internet access (all the docker images have been already loaded locally in the kube cluster)

If I run “helm install”, instead of “helm upgrade”, it seems that job upgrade is not run